
XMind  
XMind is a mind mapping and brainstorming software, developed by XMind 
Ltd. In addition to the management elements, the software can be used to capture 
ideas, clarify thinking, manage complex information, and promote team 
collaboration. 

Mind Mapping 

 
Mind mapping is the “art” of creating a visualization of some process or 
decision. It consists of a series of topics or steps that are linked together. 
Once a process has been mapped, it can be converted to template or 
model that can be modified and/or extended to other processes or 
decisions. Once these building blocks or “steps” are noted at a general 
level, attention can turn to how they are connected as well as what they 
entail. Since mind mapping is learning, it takes on a continuous nature in 
which new knowledge can be integrated.  

 
 
 

Installing XMind: 

1. Download the free version of XMind deb file which includes 32 and 64 bit versions (download 
links below). 

2. Once you have the deb file. Double click it to start the installation. 



 

ADVERTISEMENT 

 

 

 

Once you click Install Package, you’ll be prompted for the admin password in order to begin the 
installation. 



 

3. Once installed click close. 

 

 

 

 

 

 

 

 

 



1.Once The Xmind is installed you will get the following wizard which shows different 
. 

 

 

 

2.Once one of template is selected we can start working on developing our project 
concept or plan. 
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Example Tempplate with all features:
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Feature of Xmind 

 



Purpose of MindMap tool: 

A mind map is a tree chart that organize information 
the mind map as presentation slideshows. Your presentation software = mind map software.

Here is what a real life mind map presentation can look like

 

We can customize mind map templates?

1. Pick a mind map template from this blog post or XMind Share.
2. Download the template you like. Then

required. All the necessary features are free to use
3. Open the XMind file. Double

SPACE to edit). 
4. Use ENTER to add same
5. Present directly in the software.
6. (Optional) Export to PNG or email mind maps for f
7. More cool features below… Here’s a sneak peek of what XMind editor looks like:

 

 

 

 

 

 

 

A mind map is a tree chart that organize information visually. Mind map presentation is to use 
the mind map as presentation slideshows. Your presentation software = mind map software.

Here is what a real life mind map presentation can look like––

mind map templates? 

template from this blog post or XMind Share. They are ALL free to use
Download the template you like. Then download XMind to use them.

All the necessary features are free to use. 
Open the XMind file. Double-click on any text box to edit the text (or select a box and tab 

Use ENTER to add same-level boxes, TAB to add sub-level boxes. 
Present directly in the software. 
(Optional) Export to PNG or email mind maps for free. 
More cool features below… Here’s a sneak peek of what XMind editor looks like:

visually. Mind map presentation is to use 
the mind map as presentation slideshows. Your presentation software = mind map software. 

 

They are ALL free to use. 
to use them. No account registration 

click on any text box to edit the text (or select a box and tab 

More cool features below… Here’s a sneak peek of what XMind editor looks like: 



Using   XMind 

Create New Workbook 

There are two alternatives for creating a new Workbook from scratch: 
selecting a Blank Structure; or, Selecting a Template. 

 
Blank File Creation Options 

 
Depending on your project, you might find a prepared template that you 
can use as is or that you can modify for your needs. This will fast-track the 
process and give you some ideas that you might adopt in your work. 
File from Template 



 
 

 

XMind uses the term Workbooks to refer to separate Files. Once you launch 
XMind and choose Blank or Template, it will open a new workbook that 
shows up as a tab name “Untitled.”
 

Workbooks 

 
 
XMind Workbook Sheets

Basic Structure/Features 

Depending on whether you selected a Blank form or a Template, you will 
see the same basic structure with several features. These include: 1) 
Ribbon options which toggle on for more detailed choices, 2) Common 
tasks as shortcuts, 3) a list of Open XMind Wor
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XMind Workbook Sheets 

 

Depending on whether you selected a Blank form or a Template, you will 
see the same basic structure with several features. These include: 1) 
Ribbon options which toggle on for more detailed choices, 2) Common 
tasks as shortcuts, 3) a list of Open XMind Workbooks (you can cut and 

XMind uses the term Workbooks to refer to separate Files. Once you launch 
XMind and choose Blank or Template, it will open a new workbook that 

Depending on whether you selected a Blank form or a Template, you will 
see the same basic structure with several features. These include: 1) 
Ribbon options which toggle on for more detailed choices, 2) Common 

kbooks (you can cut and 



paste among files), 4) a Central Topic or your starting point, just click and 
relabel (if you selected a template there will be more topics), 5) a tab 
indicating Sheets in your Workbook at the bottom (you can add more; right-
click to rename), 6) expansion/navigation options that open upon selection, 
and 7), advanced features available in the Pro version (e.g., Export to PDF, 
Brainstorming, Gantt Chart, Convert to presentation). 

 

Getting Started 

To get started, once you have a Central Topic just mouse over it and you 
can replace the text by simply typing into the box. If you want to wrap text 
to keep the box small, use SHIFT-Return to start a new line.  

At this point, Click on the Central Topic box and enter the TAB key; this 
creates a subtopic. 

 If you want multiple tabs coming from the Central Topic, just click on the 
box and enter TAB again. To create a hierarchy, Click on the Subtopic and 
TAB.  

You can repeat this process to lay out your basic structure. 
Although you should give some thought to the layout and structure of 
your map, it is often more important to get your thoughts/topics on the 
screen.  
Once there, you can easily CLICK on a topic and drag it to a new 
location;  
that will alter the map and move the TOPIC and any SUBTOPICS to the 
same branch or location.  
The UNDO Icon in the favorites bar let’s you roll back changes 

 

 

 

 

 



XMind Layout 

 
 
 
 

Add Topics and Subtopics

Overview 

There are three ways to populate your XMind; using the tab key to add to 
each topic/subtopic, adding in the Outline Feature, or using the Insert Tab 
and drop-down menu.  

There are four kinds of topics:

 Central Topic (the starting point),

 Main Topic (first level), 

Subtopic (multiple layers of topics), 

and Floating Topics (placed anywhere without linkages).
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Create Topics by Tabs 

 
 
 
 
Create Topics Via Insert Tab

You can also Create Topics by using the Insert Tab and selecting from 
the dropdown menu. In addition to pointing to the Insert Tab, you can use 
the shortcut ALT-I (note, this syntax is used for each of the Menu items). 
As noted, the topics can be placed anywhere depending on which Topic 
you highlighted and which option you selec

 
Insert Topics 

 
 
 

 

Create Topics Via Insert Tab 

You can also Create Topics by using the Insert Tab and selecting from 
dropdown menu. In addition to pointing to the Insert Tab, you can use 

I (note, this syntax is used for each of the Menu items). 
As noted, the topics can be placed anywhere depending on which Topic 
you highlighted and which option you select. 

Once you have created topics, you can 
rename them by clicking on the Topic and 
typing in the desired label. If you want to wrap 
text to 2 lines, use CTRL-ENTER.

You can also Create Topics by using the Insert Tab and selecting from 
dropdown menu. In addition to pointing to the Insert Tab, you can use 

I (note, this syntax is used for each of the Menu items). 
As noted, the topics can be placed anywhere depending on which Topic 

Once you have created topics, you can 
rename them by clicking on the Topic and 
typing in the desired label. If you want to wrap 

ENTER. 



 

Floating Topics 

Floating Topics can be added via the Insert Menu or by quickly double-
clicking oh the open Map. This is useful for brainstorming and getting 
Topics on the Map which can later be placed where they belong and 
populated with more detail. Floating topics can be renamed, and can have 
Subtopics enhancements. 

 

Floating Topics to Brainstorm 

 
 
 
 
 
 
 
 
 
 
 
 

 

Change Order or Layout of Topics on a Map 

To move topics, simply drag and drop once a connection is automatically established. Sub 
Topics can also be inserted to change the order and/or add more features to the map. 
Connections can be deleted which creates a form of Floating Topic



 
 
. 

 
Changing Map Layout/Topics 

 
 
 
Expanding/Collapsing Topics 

For each Topic/Subtopic you create, XMind will add a placeholder until 
you rename it. To the right of each Topic with Subtopics, a small + Icon 
appears. You can toggle that on and off by clicking on it. In Expand 
mode the Subtopics will be shown; in the Contract mode (-) the 
Subtopics will be hidden. 



Expand/Contract Icons 

 

 
 
 
 
 
 
 

Mind Map Structure 

In some cases, changes to the order of topics may change the basic 
format/structure of your map. To apply a different Structure or Layout, 
RIGHT-CLICK on the topic of interest 

 
 



 
 
Changing Structure 

To Change the Structure of a Map, go to the MAIN Topic and RIGHT-
CLICK. At this point you will see “Structure” as a menu option. 

 

 
 

 

Select Structure for Changes to Selection 



 
 
 

Fishbone Structure & Optional Themes 

 

 

 
Outline View and Thumbprint 

To View Outline Panel, click on icon to upper right. You can change labels 
and/or add topics from either the map or the Outline Panel. The TAB 
addition will work in either and the results will show up in the other frame. 
Another useful feature for larger mind maps is the Thumbnail preview 
screen activated by clicking on the EYE-icon. If you scroll around in the 
preview, the larger Mind Map moves around s as well. 



Create Topics in Outline 

 
 
Changing Formats 

There are a number of ways of accessing the Format options, including 
RIGHT-CLICK on a topic or selected group of topics. Again, you do not 
have to completely enfold the 
each one to include it in the changes.

 

 

There are a number of ways of accessing the Format options, including 
CLICK on a topic or selected group of topics. Again, you do not 

have to completely enfold the topics of interest, but just overlap part of 
each one to include it in the changes. 
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topics of interest, but just overlap part of 



 
  

Adding Sheets 

 
Inserting Sheets via Menu

 

 
 

Inserting Sheets via Menu 

 You can 
also Insert 
New Sheet 
from the 
menu. This 
allows you to 
select from 
prepared 
templates for 
various types 
of activities, in 
this case, a 
problem- 
solving model. 

 
 



Make Sheet from Topic 

Once you have a basic structure, you can make separate worksh
each element.  

 

New Sheet from Topic. The Insert also allows you to create a new sheet 
with the same name as the topic and Link to it from the Main menu. 
Alternatively, select topic and right click to see Insert Sheet. This will pull 
the Topic and its Subtopics. Note that editing at the Sheet Level will not 
show up at the Main Level so you should think about how detailed you go 
for each Sheet. 

 

File Menu 

 
 

File Menu 
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New Sheet from Topic. The Insert also allows you to create a new sheet 
with the same name as the topic and Link to it from the Main menu. 
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The File Menu is fairly familiar, 
containing the basic New, Open 
Recent, and Close functions. 
The Save functions provide 
some additional options 
including Versioning in which 
XMind keeps a copy and log of 
your files without requiring any 
naming convention. However, if 
you are collaborating with 
others and/or making 
continuous changes, I 
recommend adopting some 
version number (e.g., 
Project1_v1) to make sure you 
and your colleagues are both 
looking at the same file.
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If you have the Pro version, there 
are some additional feature related 
to Password Protection, Import and 
Export. Sharing gives you a 

number of options for providing 
others access to your maps, 
either in public or private 
forums. 

 
 
 
 
 
 
 
 
 

Edit 

Overview 

The Edit Menu allows you to perform some common tasks. Whether the 
individual items are available depends on whether you are on a TOPIC 
when you select the Edit Menu or elsewhere on the map. In general, the 
shortcuts are the same as most operating systems, including Undo, Cut, 
Copy, Paste. 

 

 

 

 . 

 



File Menu 

 
 
 
 
 

Insert Menu 

The Insert Menu has a number of 
features that can be used in building 
out your mind maps. Depending on 
whether you are on a Topic or the 
general map canvas, different options 
will be bold and active vs. greyed out. 

 
 

Insert Menu Options 

Relationships 

The Relationship task allows you to visually point out how some elements 
feed into others. This is more of visualization than a project plan since 
project planning is a separate component of the Pro version of XMind. 

 

 

Showing Relationships 



 

 
Boundary 

In addition to Callouts, you can visually highlight an area or set of topics by 
Inserting a Boundary. You do not have to completely enfold the topics to 
select; just touch them while clicking the Left

 
Boundary Highlight 

 
 

 
 
Summary 

In addition to Boundaries and Callouts, you can Insert Summary to 
indicate how certain Topics/Subtopics feed into some conclusion. This is 
accomplished similar to boundaries by highlighting the Topics/Subtopics 
and then Insert Boundary.
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Boundaries and Callouts, you can Insert Summary to 
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Creating a Summary 

 

 
 
 
 
Once you have created a Summary button, you can edit it and add 
features to populate it with information and/or links.

 

Adding to a Summary

Once you have created a Summary button, you can edit it and add 
features to populate it with information and/or links. 
Once you have created a Summary button, you can edit it and add 



A few snapshots On Xmind mind mapping tool 

 

Faculty participated in Xmind training

Faculty  summarizing  Xmind tool

On Xmind mind mapping tool  Training: 
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Faculty  summarizing  Xmind tool Output of Xmind Tool

 
A Snapshot of Xmind Training 

 
Output of Xmind Tool 



 


